phpMyAdmin – Methods with the same name as their class – error

Poniższe błędy występują w Ubuntu 16.04 z wersją PHP 7.0+

Methods with the same name as their class will not be constructors in a future version of PHP; StringReader has a deprecated constructor.

Sposobem na tymczasowe pozbycie się ich jest ręczna edycja 2 plików. Drugą opcją jest czekanie na wydanie poprawionej wersji. Poniżej rozwiązanie dla osób, które lubią szybko pozbyć się problemu. Czytaj dalej phpMyAdmin – Methods with the same name as their class – error

Brak rozszerzenia mcrypt. Proszę sprawdzić konfigurację PHP.

Jeżeli w phpMyAdmin’ie na dole wyświetla się Wam komunikat: „Brak rozszerzenia mcrypt. Proszę sprawdzić konfigurację PHP.”, aby się go pozbyć w Ubuntu 12.04 wystarczy wydać poniższe polecenie:

root@server:# apt-get install php5-mcrypt

po zainstalowaniu biblioteki mcrypt musimy przeładować konfigurację serwera apach:

root@server:# service apache2 reload

Po ponownym zalogowaniu do phpMyAdmin’a komunikat informujący o braku mcrypt powinien zniknąć.

Jeśli nadal występuje można wykonać poniższe polecenie:

root@server:# php5enmod mcrypt

i ponownie zrestartować Apache’a:

root@server:# service apache2 restart